Corrigindo Erro: main.CRITICAL: pdo_mysql extension is not installed

Correção para erro:

[2022-04-27 12:25:57] main.CRITICAL: pdo_mysql extension is not installed {“report_id”:”cf078938a46ddf8c52950aa11039cfe093eff19f8bba41c99fdb19d4453eee8e”,”exception”:”[object] (Zend_Db_Adapter_Exception(code: 0): pdo_mysql extension is not installed at /vendor/magento/framework/DB/Adapter/Pdo/Mysql.php:399)”} []

Este erro corre pela falta da extensão pdo_mysql no PHP

Certifique-se se a mesma está instalada para o PHP que está sendo executado/rodando no NGINX/APACHE.

Talvez a versão que está configurada para rodar no terminal da Maquina ex:

Não é a versão que está configurada no conf do Magento (ex: Nginx)

Execute o comando a seguir com usuário Root para instalar todas as Extensões necessárias

sudo apt-get install -y php7.4-cli php7.4-json php7.4-common php7.4-mysql php7.4-zip php7.4-gd php7.4-mbstring php7.4-curl php7.4-xml php7.4-bcmath

Repare que estou instalando para versão 7.4 do PHP 

Dúvidas? Faça um comentário logo abaixo ou envie uma mensagem clicando aqui.

O seu endereço de e-mail não será publicado.